Firefox 4 : Forcer la compatibilité des extensions

Les innombrables extensions font assurément la force et le succès de Firefox. Mais celles-ci représentent d’un autre côté un inconvénient non négligeable dans le sens où elles sont dans bien des cas à l’origine du refus de mise à jour du navigateur de la part des utilisateurs. Ne souhaitant pas perdre une fonctionnalité apportée par un module complémentaire incompatible, d’anciennes versions de Firefox sont ainsi conservées.

Pour les early adopters et autres passionnés souhaitant rapidement bénéficier de la nouvelle mouture majeure du butineur, ie. Firefox 4, la solution est de forcer la compatibilité des extensions. Nul besoin donc de patienter jusqu’à ce que les développeurs appliquent les modifications nécessaires pour rendre les modules complémentaires compatibles.

Pour ne pas tenir compte des restrictions imposées par Firefox 4 et éventuellement faire des retours sur le bon fonctionnement des extensions, il suffit d’installer Add-on Compatibility Reporter.

La compatibilité de ce module sortant tout droit des ateliers de la fondation Mozilla elle-même est à l’heure où je vous parle assurée jusqu’à la version 4.0b8pre. A noter que l’éditeur déconseille de l’utiliser en dehors des releases alpha et bêta.

Baptiste Simon aka TiChou

Ingénieur développeur web dans le secteur du e-commerce et du tourisme mais avant toute chose passionné par internet et ses intarissables ressources.

2 commentaires, pings et rétroliens

Partenaires et blog à la une