1&1 : Activer PHP5

Vous avez un compte chez 1and1 et avez besoin de PHP5 pour une classe que vous avez d’ores et déjà développée ou pour une autre raison. Le problème est qu’actuellement, seul PHP4 est disponible. Aïe !

Pour ceux qui se demanderait comment vérifier la version de php, créez un fichier phpversion.php contenant les lignes suivantes, envoyez-le sur votre hébergement à l’aide de votre client ftp et accédez-y via votre navigateur.

<?php
	echo phpversion();
?>

Typiquement, cela me renvoie 4.4.9 (version 4 donc). On va placer un .htaccess* à la racine contenant les lignes suivantes. Si un tel fichier existe déjà, éditez-le simplement.

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

L’accès au fichier phpversion.php me retourne désormais 5.2.6 soit la version 5. Nous y sommes !

* Pour les utilisateurs tournant sous Windows, il n’est pas facilement possible de créer un fichier dont le nom commence par un point. Créez donc un fichier nommé htaccess.txt que vous renommerez .htaccess une fois envoyé sur le serveur.

Baptiste Simon aka TiChou

Ingénieur développeur web dans le secteur du e-commerce et du tourisme mais avant toute chose passionné par internet et ses intarissables ressources.

Les commentaires sont fermés

Partenaires et blog à la une